Liquid cooling issue/

Discussions about all aspects of technology, what you're doing with it and exchange of ideas and solutions to problems you might be having.

Liquid cooling issue/

Postby Dermisss on Sat Jun 02, 2012 5:45 pm

Pipes,cpu,reservoir getting white
I would like to know why my liquid cooling getting white from inside and what is it!? System is up and running about a month,used EK concentrate and distiled water,but now its all white! See pictures,hope someone will help me!

Image
Image
Image
Image
User avatar
Dermisss
UKCS Sponsor
 
Player: ☣Anger☣
STEAM_0:1:21652369
 
Posts: 139
Joined: Fri Sep 04, 2009 8:47 pm
Location: Ireland

Re: Liquid cooling issue/

Postby syco cocker on Sat Jun 02, 2012 6:20 pm

Could be some residue left inside the cooling blocks, looks like aluminium oxide to me.
I want to die peacefully in my sleep like my grandad
not screaming in terror like the passengers in his car.
User avatar
syco cocker
Senior Admin
 
Player: syco cocker
STEAM_0:0:11836468
 
Posts: 3222
Joined: Fri Sep 08, 2006 4:12 pm
Location: Kent UK

Re: Liquid cooling issue/

Postby Deathtaker27 on Sat Jun 02, 2012 6:24 pm

Looks like condensation to me,

Did you filter out all the air before you started using it normally?
Image
Thanks Podge, speccy and Tao
User avatar
Deathtaker27
Old Timer
 
Player: DT - RS
STEAM_0:1:22687060
 
Posts: 3408
Joined: Sat Mar 28, 2009 8:40 pm



Image

Re: Liquid cooling issue/

Postby Dermisss on Sat Jun 02, 2012 6:54 pm

Yes i filtered all air bubbles out,but it might me from bad quality distilled water,what you think? I think i have to buy new liquid and pipes to clean system out
Image
User avatar
Dermisss
UKCS Sponsor
 
Player: ☣Anger☣
STEAM_0:1:21652369
 
Posts: 139
Joined: Fri Sep 04, 2009 8:47 pm
Location: Ireland

Re: Liquid cooling issue/

Postby Deathtaker27 on Sat Jun 02, 2012 8:37 pm

Best bet is to ask at forums.bit-tech.net they have watercooling experts, I'm no expert and not sure at all :/, sorry I can't be more help
Image
Thanks Podge, speccy and Tao
User avatar
Deathtaker27
Old Timer
 
Player: DT - RS
STEAM_0:1:22687060
 
Posts: 3408
Joined: Sat Mar 28, 2009 8:40 pm



Image

Re: Liquid cooling issue/

Postby Security on Sun Jun 03, 2012 11:36 am

I had the same in my watercooling setup, but that ran for 2 years before I noticed, a month is really quick.
Image
User avatar
Security
Experienced Member
Honorary UKCS Member
UKCS iSeries Attendee
 
Player: Security
STEAM_0:0:8446840
 
Posts: 1901
Joined: Mon Oct 26, 2009 11:03 pm
Location: In the dishwasher.

Re: Liquid cooling issue/

Postby Ragonz on Mon Jun 11, 2012 11:09 pm

Did you clean out all of your components first? Looks like the crap left over when they finish making a radiator
Asus Sabertooth X58 Motherboard | I7 -950 @ 5.2Ghz | Crucial 18GB 1600Mhz Ballistix memory | Saphire HD7970 | Coolermaster 700W PSU | Watercooled

Xfire - Ragonz
Steam Rush Evo
http://www.Pingperfect.com
Ragonz
Home Member
UKCS iSeries Attendee
 
Player: -=TSH=-Ragonz
STEAM_0:1:2842690
 
Posts: 380
Joined: Wed Jun 01, 2011 9:13 am



Image


Return to PC World, Technology and Gadgets

Who is online

Users browsing this forum: CommonCrawl [Bot] and 0 guests