New mouse /again u.u

Discussions about all aspects of technology, what you're doing with it and exchange of ideas and solutions to problems you might be having.

New mouse /again u.u

Postby Mockingjay on Mon Aug 06, 2012 4:22 pm

Hello guys. After having a problem with my MX518 (random disconnect and connect) I asked Logitech to give me new one, and they sent me one G400 around 3 months ago. Oke finally it’s starting to do the same problem as MX518 .

Should I ask warranty to get new one or buy a new one ;( being the second option I thought about this mice.

- Razer Deathadder
-CM Storm Z3R0
-Steelseries Sensei

So yeah. At the moment I’m using QcK+ with G400 .thanks for reading, hope an answer


Mockingjay
Recruit Member
 
Player: MrMike @ mix/merc
STEAM_0:1:24383697
 
Posts: 10
Joined: Thu Jun 28, 2012 1:40 pm



Image

Re: New mouse /again u.u

Postby Deathtaker27 on Mon Aug 06, 2012 4:27 pm

Have you tried re-installing the drivers?

I would get it replaced, then you could always sell it as bnib and put that money towards a new mouse?
Image
Thanks Podge, speccy and Tao
User avatar
Deathtaker27
Old Timer
 
Player: DT27
STEAM_0:1:22687060
 
Posts: 3408
Joined: Sat Mar 28, 2009 8:40 pm



Image

Re: New mouse /again u.u

Postby ApacheFlame on Mon Aug 06, 2012 5:40 pm

Are you using a logitech keyboard too?

If so then dont plug them into the same usb HUB, for instance front port headers. This caused me to have the same issue on a G510/G500 keyboard/mouse combo.
The Programmers Mantra: Declare Variables, not War.

Image
Image
User avatar
ApacheFlame
Exec. Admin (Retired)
Moderator
UKCS iSeries Attendee
 
Player: Apache
STEAM_0:1:27288431
 
Posts: 5300
Joined: Tue Dec 22, 2009 1:12 am
Location: over at the Frankenstein place



Image


Return to PC World, Technology and Gadgets

Who is online

Users browsing this forum: CommonCrawl [Bot] and 1 guest