Heavy spikes lag, low ping

Forum for discussion on the UKCS:TF2 Servers

Heavy spikes lag, low ping

Postby _yog on Sat Jul 11, 2015 6:32 pm

Hey there,

It's been a few months now that I'm regularly experiencing heavy lag spikes despite having a ping around 30ms.


My computer is decent enough to run the game, no problem on that side, plus I've been using the same computer before with no lag.

The Internet lord brought me to several topics around the web where people face similar problems (such as: http://steamcommunity.com/app/440/discu ... 527775027/). However, none of the solution suggested in those topics did any trick for me.

I tried to reinstall both Steam and tf2, with no luck. I'm playing both on Windows and Linux platform and I reinstalled both, which makes me think problem is elsewhere.
FYI, I'm on Virgin Media 30Mb

This was annoying but I dealt with that as I'm not a comp player but since the Gun Mettle update, it has become ridiculously stupid... lag spikes sometimes froze my screen for close to a second... to come back to me being dead because I obviously did not dodge a rocket properly.
From my observation, it is not completely related to the amount of people I've got around me. I experience spikes even in open field where I'm happily running toward front line, but the spikes are shorter. It is just not completely smooth. I even sometimes turn around a corner and realise a second later that I'm still stuck by the wall.
I'm almost to the point where I do not want to play the game anymore, and that's sad :/

Anyone got any clue ?
Image

Thanks
.
_yog
UKCS Sponsor
 
Player: _iamyog
STEAM_0:1:24590711
 
Posts: 10
Joined: Wed Feb 19, 2014 2:11 am

Re: Heavy spikes lag, low ping

Postby Enigma on Sun Jul 12, 2015 9:24 am

_yog wrote:FYI, I'm on Virgin Media 30Mb
There's your problem. Get a decent provider like Sky. I used to have Virgin and the loss/choke was horrible.
Image
User avatar
Enigma
UKCS Sponsor
 
Player: nice dead server lmao
STEAM_0:1:29505170
 
Posts: 1324
Joined: Thu Mar 11, 2010 12:04 pm

Re: Heavy spikes lag, low ping

Postby hagz on Sun Jul 12, 2015 11:24 am

are you using a wired or wireless connection to the internet
Image
Image
User avatar
hagz
Senior Admin
 
Player: ES'9/Hagz
STEAM_0:1:5480023
 
Posts: 1429
Joined: Sat Jan 04, 2014 8:39 pm
Location: Wiltshire, Salisbury



Image

Re: Heavy spikes lag, low ping

Postby _yog on Sun Jul 12, 2015 11:41 am

Wired connection. I even tested with a new cable but it did not change anything.

Changing ISP is not on the possibility list soon but I might try to contact them. I guess mentionning "video game lag spikes" is not going to be helpful so I'll gently lie and pretend that visiting the x-factor website is far from "a smooth experience"
.
_yog
UKCS Sponsor
 
Player: _iamyog
STEAM_0:1:24590711
 
Posts: 10
Joined: Wed Feb 19, 2014 2:11 am

Re: Heavy spikes lag, low ping

Postby heuji on Mon Jul 13, 2015 7:58 am

Enigma wrote:
_yog wrote:FYI, I'm on Virgin Media 30Mb
There's your problem. Get a decent provider like Sky. I used to have Virgin and the loss/choke was horrible.

i'm on the 100mb connection, and while i disagree in principle with this, virgin has been pretty bad of late. i get 12-20ms on ukcs and i still spike a little much like yourself. the more obvious one for me is my connection to german servers. usually im 35-45 but recently its been 80+ (it seems specifically german servers too as other servers in europe seem ok)
a few things i can suggest is try dx8.1 as the new patch heavily relys on dx9, defrag, etc. but i think it will be in vain. you'll just have to tough it out i think. try running a normal map offline using the 'map' command and see how that goes, then try running a local server, they're the best ways to find if its your pc. i have heard of other people with great pc's having problems with the new patch.
☁ every cloud has a silver lining, it's called rain! ☁
Image
User avatar
heuji
UKCS Sponsor
 
Player: heuji
STEAM_0:0:5401050
 
Posts: 688
Joined: Sun Nov 13, 2011 11:30 pm
Location: Edinburgh



Image

Re: Heavy spikes lag, low ping

Postby Capn-m0nkeynutz on Mon Jul 13, 2015 8:31 am

I've been having the same as of late too, which has been a bit of a pain. I think it is down to bufferbloat, which could be inside of my home network, but it is probably Sky being crap too.

But I am only on Sky's 20mbit connection so it isn't great. Seems to be that whenever my fiancée loads a youtube video, it kills the game - but playing the same video in my computer while the game is running seems to be fine. Not sure what is happening there. Seems to help now that I have switched to a wired connection rather than wireless, but still quite bad at times.

I've been using this tool to try and see what it could be, maybe it might help? http://netalyzr.icsi.berkeley.edu/
Image

http://capn.m0nkeynutz.net - http://www.facebook.com/m0nkeynutz

Team Fortress 2 admin and maker of pretty things :)
User avatar
Capn-m0nkeynutz
UKCS Admin
Events Head
 
Player: Capn`m0nkeynutz
STEAM_0:1:16637417
 
Posts: 83
Joined: Tue May 27, 2014 10:16 pm
Location: England



Image

Re: Heavy spikes lag, low ping

Postby hagz on Mon Jul 13, 2015 12:03 pm

I know a couple of friends on virgin connections whose pings have doubled in the UK sounds like an issue with the ISP.
Image
Image
User avatar
hagz
Senior Admin
 
Player: ES'9/Hagz
STEAM_0:1:5480023
 
Posts: 1429
Joined: Sat Jan 04, 2014 8:39 pm
Location: Wiltshire, Salisbury



Image

Re: Heavy spikes lag, low ping

Postby _yog on Mon Jul 13, 2015 8:04 pm

heuji wrote:try dx8.1 as the new patch heavily relys on dx9, defrag, etc. but i think it will be in vain. you'll just have to tough it out i think. try running a normal map offline using the 'map' command and see how that goes, then try running a local server, they're the best ways to find if its your pc. i have heard of other people with great pc's having problems with the new patch.

I'm going to do all of that and update this post with results. Thanks
Update: local server and map command all run perfectly fine with no lag whatsoever. That lets Virgin as the culprit.

Capn-m0nkeynutz wrote:But I am only on Sky's 20mbit connection so it isn't great.

There was a time were people would chuckle reading "only on 20mbits" :D

Capn-m0nkeynutz wrote:Seems to be that whenever my fiancée loads a youtube video, it kills the game

Had the same issue since ever. Anyone else downloading a file or using the connection for anything while I play is barely noticeable, but as soon as youtube is launched, I jump to 900ms ping (nope, there is no mistake in the amount of 0 after the 9)

Capn-m0nkeynutz wrote:I've been using this tool to try and see what it could be, maybe it might help? http://netalyzr.icsi.berkeley.edu/


I've got this issue :

Network buffer measurements (?): Uplink 2200 ms, Downlink 290 ms

We estimate your uplink as having 2200 ms of buffering. This is quite high, and you may experience substantial disruption to your network performance when performing interactive tasks such as web-surfing while simultaneously conducting large uploads. With such a buffer, real-time applications such as games or audio chat can work quite poorly when conducting large uploads at the same time.


but on their explanation page it says that I should be able to do one thing at a time without problem (either gaming, using torrents, etc) but not two simultaneously.
I'll still try to investigate that lead just in case.

hagz wrote:I know a couple of friends on virgin connections whose pings have doubled in the UK sounds like an issue with the ISP.

And yet Virgin is sending me crappy junk mail twice a month to make me join their "amazing" mobile/tv offer... guess they won't fish me soon :)

Thanks for your answers all.
.
_yog
UKCS Sponsor
 
Player: _iamyog
STEAM_0:1:24590711
 
Posts: 10
Joined: Wed Feb 19, 2014 2:11 am

Re: Heavy spikes lag, low ping

Postby heuji on Fri Jul 17, 2015 5:03 pm

virgin are fine. i've been with them since they started up here and bought out/merged with blueyonder & ntl. it's because they're rolling out the free upgrades from the 60mb connection to 100mb. i mean, they run fibre right into your house unlike most. i still don't get this desire for huge data connections. some of my smoothest gameplay was on 126k ADSL through a small company called Nildram way back in the day. ok, so pings have dropped by ~40-50ms but the connections were a lot more true and you could just compensate.

as for youtube screwing you over, no matter how much of a hog youtube is it really shouldn't be affecting you so bad. especially if youre hardwired and the other connection is wifi. phone them up and i'm pretty sure they'll send you a new superhub as it sounds like it's borked. i actually have 1 brand new and boxed superhub as they sent me one last time i had a problem. it was just the power supply that failed but they sent me the whole lot. they basically just throw them at you.
i have another pc here on wifi, phones, and, had laptops connecting to my network at times and never noticed 'that' much of a loss. prio is always given to the wired connection, and much like water, traffic will always take the path of least resistance first. ok, i'm on a bigger connection than you, but, 30mb is still loads. you do have a superhub, right, and not routing through your pc? if not, get one.
☁ every cloud has a silver lining, it's called rain! ☁
Image
User avatar
heuji
UKCS Sponsor
 
Player: heuji
STEAM_0:0:5401050
 
Posts: 688
Joined: Sun Nov 13, 2011 11:30 pm
Location: Edinburgh



Image

Re: Heavy spikes lag, low ping

Postby _yog on Mon Aug 24, 2015 8:43 pm

Update, in case anyone with similar problem read this thread later.

I contacted Virgin via their online chat. Technical support dropped the much beloved easy answer "I see you haven't restarted your router for more than 7 days, please do and recontact us" even though I specified I've been restarting the stuff 10 times a day at one point when I was looking for a solution.

I nevertheless did restart and tried to reinitiate a chat but I must have missed something because I ended up chatting with a lovely lady that was in charge of billing and Virgin packages. As she wanted to redirect me toward the tech guys, I just randomly asked why I was paying for 30mb while their website was offering 50mb for the same price. She upgraded me for free from 30 to 50mb.

Out of curiosity I tried tf2 after the upgrade, and it seems that I no longer have any lag spikes... I don't know why but something had probably changed somewhere. 30mb seems to be more than enough to play tf2 decently, but 50 fixed the problem.
Biggest issue now is that I'm no longer able to land a headshot anymore as I lack practice after these months of lag :)

Thanks for the help everybody
.
_yog
UKCS Sponsor
 
Player: _iamyog
STEAM_0:1:24590711
 
Posts: 10
Joined: Wed Feb 19, 2014 2:11 am

Re: Heavy spikes lag, low ping

Postby rgslane the trackpad on Sat Aug 29, 2015 8:55 pm

Same, having a lot of packet loss and stuff as well, and some nasty ping spikes up into the late hundreds.

Changing from dx8 to dx7 did fix that though it made the game unplayable for other reasons...


rgslane the trackpad
UKCS Sponsor
 
Player: mousepad returns
STEAM_0:1:43601753
 
Posts: 117
Joined: Mon Sep 23, 2013 7:14 pm



Image


Return to UKCS : TF2 Server Chat

Who is online

Users browsing this forum: CommonCrawl [Bot] and 3 guests